MEDIA PONDERATA EXCEL

Oltre 1.000 professionisti utilizzano la nostra piattaforma per formarsi su contabilità, l’analisi, la modellazione finanziaria e molto altro.

Inizia ora anche tu ad accelerare la tua carriera!


La FinancetoBI Academy diventa Finprime Institute!

Abbiamo ascoltato i vostri feedback e i vostri suggerimenti e abbiamo creato la piattaforma definitiva!

Ma vogliamo festeggiare questo traguardo con voi! Per questo motivo potrete ottenere GRATUITAMENTE il nostro Corso di Accelerazione di Excel ed entrare a far parte di questo nuovo progetto!

Finprime Institute

Ora che vi abbiamo condiviso questa incredibile opportunità, torniamo all’articolo!

Per calcolare la media ponderata in Excel esistono due metodi principali:

  • la funzione MATRICE SOMMA PRODOTTO
  • la funzione SOMMA in forma matriciale

Ipotizziamo di avere i seguenti dati di vendita:

MEDIA PONDERATA EXCEL

In questa tabella abbiamo:

  • nella colonna A il prodotto venduto
  • nella colonna B le quantità vendute
  • nella colonna C il prezzo di vendita

Nel nostro caso, i pesi sono rappresentati dalle quantità (Units sold).

Per ottenere il prezzo medio ponderato dovremo moltiplicare le vendite di ogni prodotto per il rispettivo prezzo, sommare tutti i risultati ottenuti e infine dividere tutto per il totale delle quantità vendute.

L’operazione per calcolare la media ponderata è quindi:

[(Quantità 1 x Prezzo 1) + (Quantità 2 x Prezzo 2) + (Quantità 3 x Prezzo 3)]/(totale quantità)

Vediamo come calcolare la media ponderata in Excel velocemente.

Il primo metodo per calcolare la media ponderata è con l’utilizzo della funzione MATRICE SOMMA PRODOTTO.

La funzione MATRICE SOMMA PRODOTTO, non fa altro che moltiplicare tra di loro i componenti corrispondenti di una determinata matrice, nel nostro caso Quantità 1 x Prezzo 1, Quantità 2 x Prezzo 2 e cosi via, e restituisce quindi la somma dei prodotti.

Riprendendo la nostra tabella il calcolo che la funzione MATRICE SOMMA PRODOTTO farà è quindi questo:

  • B2 x C2
  • B3 x C3
  • B4 x C4

Somma dei risultati ottenuti.

media pesata Excel

Partiamo dalla sintassi della funzione:

=MATR.SOMMA.PRODOTTO(Matrice 1, [Matrice 2], [Matrice 3]…)

dove:

  • la matrice 1 (obbligatoria) è la prima matrice o intervallo che si desidera moltiplicare e successivamente aggiungere;
  • le matrici 2, 3 ecc… (facoltative) sono le altre matrici o intervalli che si desiderano moltiplicare e successivamente aggiungere.

Nel nostro caso, le matrici sono costituite dall’intervallo di celle contenute nelle colonne B e C.

Per calcolare la media ponderata in Excel dovremo quindi svolgere due semplici passaggi.

Il primo passaggio riguarda il calcolo del totale delle vendite che faremo appunto con la funzione MATR.SOMMA.PRODOTTO.

La funzione sarà:

=MATR.SOMMA.PRODOTTO(B2:B4; C2:C4)

excel media ponderata

Come abbiamo visto, la funzione calcolerà i valori in questo modo:

  • 2.843 x 111 = 315.573
  • 2.922 x 117 = 341.874
  • 2.805 x 129 = 361.845

e sommerà i risultati così ottenuti: il totale sarà 1.019.292.

Riprendendo l’immagine di prima:

media pesata Excel

Il secondo passaggio consiste semplicemente nel dividere il totale delle vendite per la somma delle quantità.

Per farlo usiamo la funzione SOMMA per sommare il totale delle quantità vendute:

excel media ponderata

La nostra formula diventerà quindi così:

=MATR.SOMMA.PRODOTTO(B2:B4; C2:C4)/SOMMA(B2:B4)

media ponderata in excel

Come abbiamo visto dall’esempio, la funzione generale per il calcolo della media ponderata in Excel è questa:

=MATR.SOMMA.PRODOTTO(valori numerici; pesi)/SOMMA(pesi)

I “valori numerici” e i “pesi” possono essere sia intervalli di celle (matrici) o intervalli denominati. Per poter calcolare la media ponderata devono però essere forniti entrambi gli argomenti.

Un altro metodo per calcolare la media ponderata in Excel, è utilizzare la funzione SOMMA, nella sua variante matriciale, che per alcuni risulta più semplice.

In ogni caso con entrambe le funzioni abbiamo la possibilità di utilizzare varianti più avanzate come quella per filtrare i risultati in base a una o più condizioni.

Anche in questo caso i passaggi da svolgere sono due.

Come per la funzione MATRICE SOMMA PRODOTTO, il primo passaggio riguarda la moltiplicazione dei valori.

La funzione SOMMA in forma matriciale sarà:

=SOMMA(B2:B4*C2:C4)

Con questo metodo, Excel prima moltiplicherà in riga ogni valore contenuto negli intervalli che gli abbiamo indicato e utilizzerà poi la funzione SOMMA per sommare tutti i risultati ottenuti.

Il risultato sarà sempre 1.019.292

NOTA BENE

Per versioni meno recenti di Excel, una volta compilata la funzione potrebbe essere necessario utilizzare la combinazione di tasti CTRL + MAIUSC + INVIO , invece che il semplice INVIO. Questo racchiuderà la formula tra parentesi graffe convertendola in una formula di matrice: ={SOMMA(B2:B4*C2:C4)}

Infine, come per la MATRICE SOMMA PRODOTTO, il risultato andrà diviso per la somma delle quantità, che possiamo ottenere anche qui usando la funzione SOMMA.

La formula alla fine risulterà:

=SOMMA(B2:B4*C2:C4)/SOMMA(B2:B4)

Lo scopo dell’utilizzo della media ponderata è quello di calcolare un risultato che rifletta l’importanza relativa di ciascun data point. La media semplice, invece, assegna la stessa importanza (o peso) a tutti i data point.

La media ponderata fornisce quindi risultati più accurati e una migliore comprensione del set di dati rispetto alla media semplice.

Per un analista finanziario, la funzione MATRICE SOMMA PRODOTTO per calcolare la media ponderata è una funzione molto utile, in quanto può gestire le matrici in modi diversi e aiutare a confrontare i dati in due o più intervalli.

Il concetto di media ponderata insieme alla funzione MATRICE SOMMA PRODOTTO è infatti spesso utilizzato in statistica e in finanza.

In finanza, la media ponderata è ad esempio utilizzata per calcolare i rendimenti dei portafogli, oppure può essere utilizzata per calcolare il totale degli interessi passivi dovuti da un’azienda.

Corso Excel di Accelerazione

Grazie per aver letto la guida della FinancetoBI Academy su come calcolare la media ponderata in Excel.

Imparando a conoscere e a padroneggiare queste funzioni di Excel, potrete accelerare notevolmente le vostre analisi finanziarie.

Per continuare ad avanzare nella vostra carriera, date un’occhiata a queste ulteriori risorse della FinancetoBI Academy:

Ebitda: cos’è e a cosa serve

Indici di bilancio

Cerca X: un cerca verticale potenziato

Carlo Liotto
Carlo Liotto
BI & Corporate Finance Consultant - Trainer
financetobi.com/

Benvenuti! Sono Carlo Liotto e sono il fondatore della FinancetoBI Academy. Sono uno dei principali consulenti in Italia specializzati in Finanza Aziendale, Financial Modeling e Business Intelligence. I miei clienti spaziano da start-up a PMI con fatturati da 1 a 200mln di euro in diverse industries, così come studi professionali, commercialisti e consulenti e grazie alla fusione di queste competenze generano un enorme valore dalle informazioni aziendali, per loro o per i loro clienti. Ho inoltre scritto un libro sulla strategia per start-up con uno dei più importanti editori in Italia e che potete trovare nel business center di Fisco e Tasse: https://bit.ly/startup-fiscoetasse. Nel tempo libero, metto casco, guanti, e giacca di pelle e mi metto in sella alla mia moto verso i passi di montagna.

Related Posts