CONTA SE

Conta il numero di celle che incontrano uno specifico criterio.

Oltre 1.000 professionisti utilizzano la nostra piattaforma per formarsi su contabilità, l’analisi, la modellazione finanziaria e molto altro.

Inizia ora anche tu ad accelerare la tua carriera!


La FinancetoBI Academy diventa Finprime Institute!

Abbiamo ascoltato i vostri feedback e i vostri suggerimenti e abbiamo creato la piattaforma definitiva!

Ma vogliamo festeggiare questo traguardo con voi! Per questo motivo potrete ottenere GRATUITAMENTE il nostro Corso di Accelerazione di Excel ed entrare a far parte di questo nuovo progetto!

Finprime Institute

La funzione CONTA SE conta il numero di volte in cui le celle all’interno di un intervallo rispettano un determinato criterio. È categorizzata all’interno delle Funzioni Statistiche di Excel.

Nell’analisi finanziaria è una funzione molto utile. Può infatti essere utilizzata per contare le volte che un venditore ha superato il target di vendita, le volte in cui un prodotto supera un determinato numero di vendite oppure quante volte un gruppo di studenti ha raggiunto un particolare voto.

Vediamo ora come funziona CONTA SE iniziando dalla sua sintassi.

La formula per utilizzare la funzione CONTA SE in Excel è la seguente:

= CONTA.SE (intervallo; criterio)

  • Intervallo (obbligatorio): l’intervallo di celle contenente l’insieme di dati in cui la funzione cercherà quelle che corrispondono ai criteri indicati
  • Criterio: è la condizione specifica che definiamo noi e sarà quella che deve essere soddisfatta affinché la funzione conti la cella.

Il criterio può essere:

  • Un valore numerico: può essere un valore intero, decimale, una data, un’ora o un valore logico.
  • Una stringa di testo: può includere anche wildcards (anche chiamati caratteri jolly). I caratteri jolly possono essere un ? (punto interrogativo) o un * (asterisco). Un ? corrisponde a qualsiasi singolo carattere, mentre un * corrisponde a qualsiasi sequenza di caratteri. Se si desidera trovare effettivamente il carattere ? (punto interrogativo) o * (asterisco), è necessario digitare il simbolo ~ prima di questo carattere nella ricerca.

Vediamo subito un primo esempio molto semplice.

Dato un criterio, la funzione CONTA SE cerca una corrispondenza esatta per determinare il numero totale di celle in cui la condizione è soddisfatta.

Esempio 1

Supponiamo di avere un elenco di venditori che hanno superato gli obiettivi di vendita e hanno vinto il premio come miglior venditore dell’anno.

Con la funzione CONTA SE, siamo in grado di scoprire rapidamente quale venditore ha vinto il maggior numero di premi.

conta se excel

In questo caso useremo la funzione CONTA SE in questo modo:

conta.se excel

Il risultato sarà: 3, ovvero Sofia Martinez come vincitrice del premio “Miglior venditore dell’anno” per 3 volte.

Esempio 2

Possiamo ottenere lo stesso risultato riferendoci ad una cella, in questo modo il nostro file sarà più dinamico. Ci basterà quindi inserire il nome del venditore da analizzare per ottenere il risultato desiderato:

funzione conta se

💡PRO TIP

Possiamo anche usarla insieme alla funzione CONVALIDA DATI per renderla ancora più dinamica:

funzione conta se excel

Vediamo ora alcuni esempi più avanzati utilizzando gli operatori logici.

Gli operatori che è possibile utilizzare con la Funzione CONTA.SE sono:

Operatore Descrizione
> Maggiore
< Minore
= Uguale
>= Maggiore o uguale
<= Minore o uguale
<> Diverso

Esempio 1

Ipotizziamo di avere questo set di dati contenente il numero di vendite per la prima metà del mese di dicembre 2023:

funziona conta se excel

Ecco alcuni esempi di come potremmo utilizzare la funzione CONTA.SE con questo set di dati:

  1. Conta le vendite superiori a 50: =CONTA.SE(intervallo; “>50”).
  2. Conta le vendite uguali a 45: =CONTA.SE(intervallo;”=45″)
  3. Conta le vendite inferiori a 30: =CONTA.SE(intervallo;”<30″)

Come risultato avremo:

conta.se excel

Nota bene: quando usiamo gli operatori logici, questi, insieme al numero o al testo da analizzare, vanno inseriti tra virgolette:

excel conte se

Esempio 2

Sostituiamo ora al numero nel criterio un riferimento di celle:

formula conta se

In questo modo, possiamo rendere le nostre analisi più dinamiche. Di conseguenza, ci basterà infatti cambiare il valore nella colonna E per ottenere il risultato desiderato.

Quanto utilizziamo gli operatori riferendoci direttamente alle celle, dobbiamo ricordarci di “concatenare” l’operatore al riferimento di cella.

Riprendendo l’esempio dell’immagine precedente, abbiamo infatti, al primo argomento l’intervallo di celle da analizzare, al secondo il criterio scritto in questo modo:

“>”&E6

Dove l’operatore è tra virgolette (“>”) e viene concatenato con & al riferimento di cella E6:

conte.se excel

Vediamo infine come possiamo far scalare le nostre analisi grazie alle wildcards, ovvero i caratteri jolly per ampliare le nostre capacità di analisi.

Ecco quali sono e quale il loro utilizzo:

Wildcard Descrizione
(?) Un punto interrogativo nei criteri corrisponde a qualsiasi carattere
(*) Un asterisco corrisponde a una qualsiasi sequenza di caratteri.
Ad esempio, “*a” conterà tutte le celle che terminano con “a” e “a*” conterà le celle che iniziano con “a”.
(~) Una tilde corrisponde a un carattere jolly, ad esempio “~?” conterrà tutte le celle che terminano con un punto interrogativo.

Vediamo ora come si possono usare le wildcards con la funzione CONTA.SE.

Riprendiamo l’esempio precedente dei premi ai venditori dell’anno.

conta se

In questo caso, per il 2010 la venditrice Sofia è indicata solo con il nome, senza il cognome.

Usando il carattere jolly “*” alla fine del nome, possiamo dire ad Excel di cercare tutte le celle che iniziano per Sofia. Ciò includerà quindi sia le celle che contengono solo la parola Sofia che quelle che contengono il nome per intero, ovvero Sofia Martinez.

Ecco altri esempi:

excel conta se contiene testo

Come risultato, per le diverse condizioni avremo quindi:

=CONTA.SE($A$6:$A$13;”Torino”) = 1

=CONTA.SE($A$6:$A$13;”*O”) = 4

=CONTA.SE($A$6:$A$13;”V*”) = 2

=CONTA.SE($A$6:$A$13;”??????”) = 4

=CONTA.SE($A$6:$A$13;”* *”) = 2

=CONTA.SE($A$6:$A$13;”*”) = 8

=CONTA.SE($A$6:$A$13;”*città*”) = 1

=CONTA.SE($A$6:$A$13;”<>Milano”) = 7

💡PRO TIP

La Funzione CONTA.SE è molto simile alla funzione SOMMA.SE, per cui tutti gli operatori logici e le wildcards, possono essere utilizzate anche con la funzione SOMMA.SE!

Inoltre, come funzione di Excel, la funzione CONTA SE può essere utilizzata sia da sola sia come funzione annidata all’interno di altre.

  • La funzione CONTA.SE restituisce un errore se l’argomento del criterio dato è una stringa di testo di lunghezza superiore a 255 caratteri.
  • Non viene restituito nessun valore: assicurati di racchiudere l’argomento del criterio tra virgolette.

Corso Excel di Accelerazione

Per continuare ad avanzare nella tua carriera, dai un’occhiata a queste risorse:

SOMMA.SE

CERCA Verticale in Excel

CERCA.X in Excel: un cerca verticale potenziato

Carlo Liotto
Carlo Liotto
BI & Corporate Finance Consultant - Trainer
financetobi.com/

Benvenuti! Sono Carlo Liotto e sono il fondatore della FinancetoBI Academy. Sono uno dei principali consulenti in Italia specializzati in Finanza Aziendale, Financial Modeling e Business Intelligence. I miei clienti spaziano da start-up a PMI con fatturati da 1 a 200mln di euro in diverse industries, così come studi professionali, commercialisti e consulenti e grazie alla fusione di queste competenze generano un enorme valore dalle informazioni aziendali, per loro o per i loro clienti. Ho inoltre scritto un libro sulla strategia per start-up con uno dei più importanti editori in Italia e che potete trovare nel business center di Fisco e Tasse: https://bit.ly/startup-fiscoetasse. Nel tempo libero, metto casco, guanti, e giacca di pelle e mi metto in sella alla mia moto verso i passi di montagna.

Related Posts